Laman

Kamis, 29 November 2018

Peran Arab Saudi dan Turki dibalik Berdirinya Negara Zionis Israel


Kekhalifahan Turki Ottoman adalah penakluk jazirah Arab saat. Hampir semua wilayah di Timur Tengah berada di bawah penguasaannya, termasuk Yerusalem.


Pada perang dunia 1, Inggris atau Britania Raya tentunya punya kepentingan di situ. Namun setelah 625 tahun, Kekhalifahan Turki Ottoman harus berakhir pada 1 Nobember 1922. Majelis Nasional Agung dalam sidang sejak Februari 1922 memutuskan untuk menghapus sistem khilafah Islam di Konstantinopel (sekarang Turki) dengan sistem republik yang sekuler.


Oleh masyarakat di luar Turki, peristiwa runtuhnya Ottoman & berdirinya Republik Turki mengundang simpati sekaligus kecaman. Kecaman khususnya datang dari golongan Muslim konservatif karena akibat peristiwa tersebut, Turki tidak lagi menjadi negara Islam. Kecaman juga datang dari orang-orang di luar etnis Turki karena pemerintah Turki cenderung mengucilkan hak-hak dari etnis minoritas Turki, misalnya etnis Kurdi. Namun, simpati juga datang dari golongan liberal & sekuler yang beranggapan kalau kelompok nasionalis Turki sukses membangkitkan Turki dari yang awalnya merupakan negara terbelakang di Eropa menjadi salah satu kekuatan regional seperti sekarang.

Lemahnya penguasa, perilaku korup & dzolim, perekonomian yang semakin terpuruk akibat perang & banyaknya kekalahan menyebabkan Kemunduran Kekhalifahan Ottoman. Keadaan ini diperparah dengan memunculan sentimen nasionalisme Arab yang semakin marak, maka cikal bakal perlawanan bangsa Arab kepada Ottoman pun kian tak terbendung.


Benih-benih Perang terhadap Turki Ottoman sudah muncul sejak 1915. Pada bulan Maret tahun itu, Sharif Hussein yang merupakan penguasa Hejaz saat itu mengirimkan anaknya yang bernama Faisal untuk bergabung dengan Jami’yah Arabiyah Fatat. Ini adalah gerakan di Suriah yang bertujuan menggalang kekuatan untuk melawan kerajaa Turki Ottoman. Sharif Hussein sendiri diangkat sebagai Emir (atau Gubernur) Mekkah oleh Turki pada 1909.

Peluang ini pun tidak disia-siakan oleh Inggris. Mereka menyusupkan agen mereka yakni Thomas Edward Lawrence untuk melobi Sharif Hussein.


Baca juga: Peran Thomas Edward Lawrence (Orang) Inggris di Balik Lahirnya Arab Saudi dan Kehancuran Kekhalifahan Turki Utsmani 

Hal itu rupanya adalah strategi lain dari Inggris. Iming-iming untuk Sharif Hussein itu sebenarnya cuma akal bulus belaka supaya Inggris memperoleh tambahan kekuatan untuk melawan Turki Ottoman saat perang dunia 1. Hal itu terbukti melalui surat-surat yang menunjukkan negosiasi ini disebut Korespondensi McMahon-Hussein, karena Sharif Hussein berbalas pesan dengan Komisaris Tinggi Inggris di Mesir, Sir Henry McMahon.

Pasukan berkuda Arab dipimpin oleh Pangeran Faishal bin Syarif Husain dan agen intelijen Inggris, Lawrence of Arabia, menyerbu pasukan Turki Utsmani di wilayah Jabal Druz, Baklabak, dan Ma’an. Musthafa Kamal Pasha, Panglima Pasukan Divisi VII Turki Utsmani, telah menjalin kesepakatan rahasia dengan Inggris.


Pengkhianatan Musthafa Kamal Pasha membuat pasukan Turki Utsmani yang kelaparan dan kehabisan amunisi di kota Gaza dan Ma’an kewalahan menghadapi serbuan pasukan Arab. Pasukan Turki Utsmani terpaksa ditarik mundur, sehingga kota Gaza dan Ma’an jatuh ke tangan pasukan Arab.


Kemenangan pasukan Arab itu merupakan sebuah kesuksesan besar bagi pasukan Inggris dan Sekutu. Sebab, Palestina jatuh ke tangan pasukan Inggris dan Sekutu tanpa tewasnya seorang pun tentara mereka dalam perang melawan pasukan Turki Utsmani.

Para pembelot Arab ini berhasil mengambil alih beberapa kota besar dari Ottoman. Sementara Inggris bergerak menuju Palestina dan Iraq, mengambil alih kota-kota yang kala itu masih dalam genggaman Ottoman, yakni Aqaba, Baghdad dan Yerusalem. 


Inggris menepati janjinya. Sharif Hussein akhirnya berkuasa penuh di Hejaz dan tidak lagi menjadi bawahan Turki. Setelah meninggal pada 1924, ia digantikan oleh anak tertuanya Pangeran Ali . Sedangkan Pangeran Faisal menjadi penguasa di Irak dan Suriah (dikenal dengan nama Faisal I of Iraqi ) dan anaknya yang lain, Pangeran Abdullah , menjadi penguasa di Jordan (terkenal dengan nama Abdullah I of Jordan ).


Namun Inggris tidak membiarkan Syarif Husain menikmati sedikit kue empuk hasil kerja kerasnya. Inggris secara diam-diam juga menjalin kesepakatan dengan penguasa Riyadh dan pemimpin politik gerakan dakwah tauhid Nejed, Pangeran Abdul Aziz bin Abdurrahman Al-Saud.


Pasukan Syarif Husain mengalami kekalahan telak dalam pertempuran di wilayah Turbah melawan pasukan Abdul Aziz bin Abdurrahman Al-Saud. Dengan dukungan Inggris, pasukan Abdul Aziz bin Abdurrahman Al-Saud mengalahkan pasukan Syarif Husain pada perang tahun 1343 H. Syarif Husain akhirnya lengser dan menyerahkan tahta kerajaannya kepada putranya, Syarif Ali bin Syarif Husain.


Namun, kekalahan perang telah mengakibatkan kota Makkah jatuh ke tangan Abdul Aziz bin Abdurrahman Al-Saud. Hal itu berarti Khilafah Arabiyah Makkah tumbang. Syarif Ali bin Syarif Husain mundur ke kota Jeddah. Namun pasukan Abdul Aziz mengejarnya dan mengepung kota Jeddah selama satu tahun penuh. Selain itu, pasukan pemimpin Nejed itu juga menyerang dan mengepung kota Madinah. Madinah menyerah sepenuhnya ke tangan Abdul Aziz bin Abdurrahman Al-Saud setelah dikepung selama 10 bulan. Begitupula dengan Jeddah, takluk setelah tercapai pengepungan setahun penuh. 


Berdasar kesepakatan kedua belah pihak, Jeddah menjadi wilayah kekuasaan Abdul Aziz bin Abdurrahman Al-Saud, sementara Syarif Ali dan keluarganya diberi jaminan untuk bergabung dengan saudaranya, Syarif Faishal bin Syarif Husain di Irak.

Syarif Husain sendiri dibuang ke Cyprus sebagai tahanan politik dan meninggal di pembuangan pada tahun 1350 H. Makkah, Madinah, Jeddah, dan Riyadh disatukan oleh Abdul Aziz bin Abdurrahman Al-Saud, lalu ia mendirikan Kerajaan Alu Sa’ud. Revolusi Arab yang dipimpin Syarif Husain pada akhirnya berperan menjatuhkan Palestina ke tangan Inggris dan Yahudi.

Baca juga: Deklarasi Balfour 1917 - Peran Inggris Dibalik Berdirinya Negara Zionis Israel 

Dalam sebuah dokumen resmi ditemukan surat menyurat antara Raja Abdul Aziz dengan pemerintah Inggris pada tahun 30-an, bahwa Raja Arab Saudi tidak diperbolehkan menentang sikap Inggris yang memberikan kedaulatan kepada Israel untuk mendirikan sebuah negara di kawasan Palestina. Bahkan, sikap Raja Abdul Aziz tersebut disahkan dalam sebuah fatwa keagamaan yang merupakan sikap resmi kerajaan pada tahun 90-an bahwa diperkenankan berdamai dengan Israel.


Maka dari itu, tidak aneh jika melihat sikap Arab Saudi saat ini terkait dengan kebijakan Amerika Serikat dan penjajahan Israel di Tanah Palestina yang cenderung lunak dan halus terhadap isu-isu Palestina dapat dilacak dari sejarah yang panjang. Apalagi kedaulatan dan kemerdekaan Arab Saudi merupakan "hadiah" dari Inggris.

Baca juga: Pengkhianatan Arab Saudi Terhadap Islam 

Di luar sepengetahuan Syarif Husain pada bulan Maret 1916 M penjajah Inggris, Perancis, dan Rusia mengadakan pertemuan rahasia untuk membagi-bagi bekas wilayah Turki Utsmani dan mendukung pendirian negara Yahudi di Palestina. Cara yang dipakai Inggris memanfaatkan Mustafa Kamal, agar melakukan gerakan pemberontakan terhadap Kesultanan Ottoman. Berawal dari keputusan dari Kesultanan Ottoman ambil bagian dalam Perang Dunia 1 tahun 1914, ternyata menjadi blunder mengerikan.


Serupa dengan Syarif Husain & Abdul Aziz bin Saud, imbalan yang diberikan Inggris adalah kekuasaan. Musthafa Kamal Pasha menarik mundur pasukannya tanpa menembakkan sebutir peluru pun terhadap pasukan musuh. Atas pengkhianatannya itu, Inggris memberikan hadiah Musthafa Kamal Pasha sebagai penguasa Turki.


Tanggal 29 Oktober 1923, parlemen nasionalis Turki mendeklarasikan berdirinya "Republik Turki" (Turkiye Cumhuriyeti) sebagai negara penerus resmi Kesultanan Ottoman. Pendirian republik juga diikuti dengan reformasi di banyak bidang. Turki ditetapkan sebagai negara dengan konstitusi & sistem hukum sekuler. Mustafa Kamal Atatürk dan Majelis Agung Nasional (GNA) menghapuskan kekhalifahan itu sendiri, dan mengirim semua anggota kekhalifahan yang tersisa dari keluarga Ottoman ke pengasingan.



Turki mengamandemen Undang-Undang Dasar 1924 hanya empat tahun setelah diresmikan dan menghapus Islam sebagai agama resmi negara. Bahasa & aksara Turki ditetapkan sebagai bahasa resmi negara menggantikan aksara Arab. 

Mustafa Kemal ditetapkan sebagai bapak bangsa dengan gelar "Ataturk". Penduduk Turki dianjurkan mengenakan pakaian yang mirip dengan model pakaian masyarakat Barat. Bahkan hingga tahun 1950, adzan di masjid-masjid diwajibkan memakai bahasa Turki.

Tak hanya adzan, Al-Quran pun semuanya harus berbahasa Turki, termasuk bacaan-bacaan dalam sholat. Peraturan menikah di Turki, mahar (mas kawin) minimal 90 gram emas. Belum termasuk pemberian gelang, cincin, dan perhiasan lainnya. 90 gram emas adalah murni mahar untuk si calon pengantin yang akan diperistri.

Foto Mustafa Kemal Attaturk banyak dipajang di tempat-tempat umum, di rumah-rumah, dan di banyak tempat. Bagi masyarakat Turki, Kemal Attaturk adalah pendiri bangsa yang heroik, bagaikan sesosok malaikat yang turun dari surga.


Sebelum menjadi Bapaknya orang Turki, diketahui Mustafa melakukan intrik-intrik khusus. Misalnya memposisikan dirinya sebagai pahlawan dengan mengusir Inggris dan Yunani dari tanah Turki. Terkesan heroik. Menghilangkan kekhalifahan yang sudah dirintis sejak ratusan tahun lalu dan menjadi simbol kebesaran umat Islam, tentu saja ini adalah sebuah hal gila yang mungkin tak termaafkan.

Aturan berikutnya yang membuatnya terkesan seolah membenci Islam adalah mulai menghapuskan sistem-sistem yang berbau keislaman di berbagai sisi. Ia kemudian mengadopsi sistem barat sebagai penggantinya. 


Pengaruh dari itu, kini semua wilayah kota di Turki, dari segi pakaian masyarakat Turki tidak jauh berbeda dengan masyarakat Eropa. Hari ini penyimpangan sexual (LGBT) legal di Turki. Namun tidak ada undang-undang yang melindungi kaum gay, lesbian, dan transeksual dari diskriminasi.




Referensi:

Buku : Dinasti Bush Dinasti Saud (2004).
By Craig Unger
(mantan deputi director New York Observer).

Buku: Library of Middle East History , Volume 10, 2006:15.
By Weldon Matthews.

Buku: The Saudi Enigma: A History, 2005:81.
By Pascal Menoret

Buku: A Companion to International History, 2008:134.
By Gordon Martel


Buku: Britain Through Muslim Eyes, 2015.
By Claire Chambers

Buku: Timur Tengah di Tengah Kancah Dunia.(1992)
By George Lenczowski
(diterjemahkan ke dalam bahasa Indonesia).

Buku: History oh the Arabs (2006).
By Philip K. Hitti

Artikel “Lawrence of Arabia was a Zionist” dimuat Jerusalem Post edisi 22 Februari 2007.
Penulis: Martin Gilbert

Nabi Yusya' bin Nun (Joshua) as


Yusya‘ bin Nūn ( Arab: ﻳﻮﺷﻊ, Ibrani : יְהוֹשֻׁעַ Yehoshua/Joshua adalah salah seorang nabi yang memimpin Bani Israel memasuki tanah Palestina. Nabi Yusya' bin Nun merupakan keturunan dari Ifrosun bin Yusuf AS bin Ya'kub AS bin Ishaq AS bin Ibrahim AS.

Nama Nabi Yusya’ a.s. tidak disebutkan secara eksplisit di dalam Al-Qur'an, akan tetapi beliaulah yang mendampingi Musa ketika keduanya berjalan hingga bertemu dengan Nabi Khidir a.s. seperti yang tertuang dalam sebuah ayat di Surah Al-Kahfi :


ﻭَﺇِﺫْ ﻗَﺎﻝَ ﻣُﻮﺳَﻰ ﻟِﻔَﺘَﻯﻪُ ﻟَﺂ ﺃَﺑْﺮَﺡُ ﺣَﺘَّﻰٓ ﺃَﺑْﻠُﻎَ ﻣَﺠْﻤَﻊَ ﭐﻟْﺒَﺤْﺮَﻳْﻦِ ﺃَﻭْ ﺃَﻣْﻀِﻰَ ﺣُﻘُﺒًﺎ

Dan (ingatlah) ketika Musa berkata kepada muridnya: "Aku tidak akan berhenti (berjalan) sebelum sampai ke pertemuan dua buah lautan; atau aku akan berjalan sampai bertahun-tahun." (Q.S. Al-Kahfi [18]: 60)


Menjelang akhir hayatnya, Nabi Musa a.s. menyadari bahwa saat-saat yang ditunggu telah tiba bagi kaumnya untuk memasuki tanah yang dijanjikan, meskipun tanpa kehadiran dirinya. Melalui bimbingan Allah SWT, Nabi Musa pun mempersiapkan seorang Yusya' bin Nun a.s., sebagai pemimpin Bani Israil menggantikan dirinya.



Sepeninggal Nabi Musa, Nabi Yusya memulai persiapan untuk memasuki Yerusalem, dengan cara menembus Benteng Kota Yerikho pun mulai dilakukan. Ia kemudian mengirim dua orang pengintai untuk mengamati wilayah kota itu. Hampir saja kedua pengintai itu tertangkap oleh pasukan Yerikho jika tidak diselamatkan oleh seorang wanita tuna susila bernama Rahab.

Dari wanita ini pulalah diketahui bahwa penduduk Kota Yerikho sebenarnya lebih takut kepada kaum Bani Israil yang mereka anggap memiliki kesaktian atau kekuatan gaib lantaran dukungan dari Yang Maha Kuasa. 

Rahab, sang wanita itu, mengatakan, "Kengerian menghinggapi kami karena Tuhan telah mengeringkan Laut Merah bagi kalian. Ketika kami mendengarnya, ciutlah hati kami dan jatuhlah semangat tiap-tiap orang dari kami, sebab Tuhan kalian adalah Penguasa langit dan bumi."

Kemudian saat yang lama dinantikan itu pun tiba, Nabi Yusya' a.s. mempersiapkan kaumnya untuk berangkat menjelang takdir penaklukan Yerusalem.

Rasulullah SAW pernah menjelaskan ihwal persiapan perang suci ini di dalam sebuah hadits:

"Salah satu dari nabi telah melakukan perang suci. Ia berkata kepada kaumnya: 'Barangsiapa yang telah menikahi seorang perempuan dan berkehendak untuk bercampur dengannya namun belum terlaksana; lalu mereka yang sedang membangun rumah namun belum menegakkan atap rumahnya; juga mereka yang telah membeli kambing-kambing dan unta-unta yang hamil dan menunggu kelahirannya, mereka itu tidak akan ikut (untuk berperang) bersamaku.' — HR. Muslim 19/4327
Nabi Yusya' mensyaratkan bahwa mereka yang ikut berperang bersamanya adalah mereka yang tidak terbuai hatinya dengan pernak-pernik dunia. Karena bukanlah jumlah prajurit yang dicari, melainkan keikhlasan dalam melaksanakan jihad ini.

Nabi Yusya berkata kepada kaumnya, "Sucikan dan teguhkanlah niatmu, sebab besok Tuhanmu akan melakukan perbuatan yang ajaib di antara kamu." Nabi Yusya' berkata kepada para imam, "Bawa dan usung Tabut Perjanjian, berjalanlah kalian di depan."



Dalam syariat Bani Israel, mengusung Tabut adalah simbol bahwasanya peperangan ini adalah sebuah perintah dari Allah SWT dan hanya dapat dilakukan dengan kekuatan-Nya semata, bukan oleh kekuatan sendiri.

Maka dimulailah perjalanan suci yang didasari atas keyakinan dan ketakwaan ini. Para imam, sembari mengangkat Tabut, berjalan di barisan terdepan memimpin pergerakan kaum Bani Israil. Sementara itu, Allah SWT telah mempersiapkan sebuah mukjizat yang tak disangka-sangka. 

Sesampai di tepi Sungai Yordan, tatkala para imam mulai mencelupkan kakinya ke dalam air untuk menyeberang, tiba-tiba aliran sungai terhenti dan terbukalah jalan kering melintasi sungai di depan mereka, persis seperti tatkala Allah SWT menyiapkan jalan kering bagi Musa dan pengikutnya membelah Laut Merah.

Pasukan Bani Israil pun menyeberangi sungai yang lebar dan dalam itu, tanpa mengalami kesulitan yang berarti. Sebelum sampai di seberang sungai, Nabi Yusya' a.s. menerima petunjuk dari Allah SWT agar memerintahkan wakil dari masing-masing suku Bani Israil — yakni sebanyak 12 suku — untuk mengambil 12 batu yang menjadi bekas injakan para imam ketika melintas di tengah sungai, untuk dibawa ke pinggir sungai dan diletakkan di tempat mereka akan bermalam.

Duabelas batu adalah simbol yang kerap dipakai untuk menandai sebuah kejadian yang spektakuler, terutama pada masa Kerajaan Yehuda sebelum kekuasaan Raja Yosiah (Ulangan 27: 1-8). Hal semacam juga pernah terjadi pada Nabi Ilyas (Elia) a.s. yang menggunakan 12 batu untuk membangun altar, sebagai tempat berkurban atau persembahan di Gunung Karmel.

Sesampai di pinggir Sungai Yordan, tepatnya di wilayah bernama Gilgal di perbatasan Yerikho, batu-batu itu pun diletakkan dengan formasi khusus, melingkar tepat di tempat para pimpinan keduabelas suku berkumpul bersama Nabi Yusya'. Hal ini dimaksudkan — sebagaimana tertulis di Kitab Yosua — sebagai pengingat bagi anak cucu mereka nanti bahwa Allah SWT telah menjadikan, di depan mata mereka sendiri, jalan kering melintasi Sungai Yordan kepada kaum Bani Israil dalam peperangan ini.

Mereka pun berkemah di Gilgal. Di sana, mereka melakukan ibadah pensucian (thaharah) dengan melakukan sunat (khitan) — yakni bagi mereka yang merupakan keturunan dari bapak atau kakek mereka yang telah melakukan pelarian dari Mesir bersama Musa a.s.

Penaklukan Yerikho

Berita tentang kedatangan pasukan Bani Israil kian santer menyebar ke seluruh negeri. Begitu pun semua pemimpin di Kanaan, mereka langsung ketakutan tatkala mendengar bagaimana Allah SWT lagi-lagi membantu Bani Israil dengan membuatkan jalan kering di perairan. Gerbang Yerikho yang besar dan kokoh itu pun ditutup rapat-rapat, tak seorang pun dapat keluar atau masuk.

Dalam Kitab Yosua dikisahkan bagaimana Nabi Yusya' dijanjikan kemenangan dan menerima petunjuk agar memerintahkan semua orang berjalan mengelilingi benteng kota itu selama enam hari, sementara para imam ditugaskan meniup trompet sangkakala yang terbuat dari tanduk domba. Di hari ketujuh, dinding benteng raksasa itu runtuh dan para prajurit Nabi Yusya' merangsek masuk ke dalam kota.

Demikianlah, ketika tangan Allah beserta sebuah jamaah, maka segala sesuatunya berada dalam genggaman dan pengaturan-Nya. Perkara meruntuhkan tembok tebal yang dijaga oleh pasukan yang gagah perkasa, tidaklah sulit bagi-Nya. Tugas para hamba-Nyalah untuk senantiasa tertib menjaga syariat dan aturan yang telah Allah tetapkan.

Dikabarkan pula oleh Rasulullah SAW di sebuah hadits bahwa tatkala Nabi Yusya' menembus Benteng Yerikho, matahari sempat dibuat berhenti beredar oleh Allah SWT. Hari itu, yakni Hari Jumat, berlangsung lebih lama dari yang semestinya. Hal ini dilakukan untuk memberi kesempatan kepada Nabi Yusya' beserta kaumnya menyelesaikan amanahnya, karena keesokan harinya sudah masuk Hari Sabat (Sabtu) di mana di hari itu, sesuai syariat yang diturunkan melalui Nabi Musa, Bani Israil diperintahkan untuk berhenti beraktivitas.

Maka ia (Yusya') berangkat hingga mendekati kota kira-kira pada waktu Ashar. Ia kemudian berkata kepada matahari, 'Hai matahari, engkau tengah menjalankan tugasmu dan aku pun sedang menjalankan tugas dari Allah. Maka, wahai Tuhanku, hentikanlah matahari!' Dan matahari pun berhenti sejenak hingga Allah mengaruniakan kemenangan kepadanya." — HR Muslim 19/4327

Hari ketujuh, setelah tembok Yorikho runtuh, Nabi Yusya' dan pasukannya menyerbu masuk ke dalam kota, dan membumihanguskan seluruh isi kota tanpa tersisa, kecuali rumah yang dihuni oleh Rahab dan keluarganya — yaitu, sang perempuan yang pernah membantu beberapa prajurit Nabi Yusya' a.s. dahulu tatkala mereka hampir tertangkap dalam tugas pengintaian. Mereka juga dilarang untuk mengambil bahan-bahan makanan atau barang-barang, kecuali emas, perak, tembaga dan besi.


Riset arkeologis oleh beberapa ahli, di antaranya oleh Dr. Garstang yang menjadi Direktur Departemen Zaman Purbakala di Palestina, menemukan banyak sisa pasokan gandum di beberapa titik yang bercampur dengan abu di kota itu. Hal ini menjelaskan bahwasanya kota itu pernah terbakar, sementara pasokan gandum masih banyak.


Penelitian Dr. Garstang ini juga memberi indikasi sebuah proses penaklukan kota yang sangat cepat, karena dalam sebuah taktik perang yang umum dalam menghadapi musuh yang berlindung di dalam benteng yang kokoh, strategi yang biasa digunakan adalah memblokade dan membuat lapar seluruh isi kota terlebih dahulu selama sekian waktu untuk melemahkan perlawanan.

Masih banyaknya cadangan makanan juga menandakan bukti bahwa pasukan Nabi Yusya' a.s. tidak mengambil benda-benda lain kecuali yang telah diperintahkan berupa emas, perak, tembaga dan besi.


Referensi:

Nabi Yusya' bin Nun : Sang Penakluk Baitul Maqdis Qudusiyah.org

Rabu, 28 November 2018

Kode Status HTTP Server Error

HTTP singkatan dari Hypertext Transfer Protocol. Sesuai namanya, HTTP adalah suatu protocol yang digunakan oleh World Wide Web, untuk mendefinisikan cara suatu pesan dapat dikirimkan dari server kepada client.


Pada umumnya sebuah client HTTP dalam hal ini web browser, akan memulai request dengan membuat koneksi TCP/IP ke suatu port tertentu. Barulah kemudian sebuah server HTTP yang menerima request di port tersebut dari client, mengirimkan balik halaman yang sudah diminta oleh client.Kode tersebut juga menjadi standard jenis error yang dapat dilihat oleh user pada tampilan web browser atau browser smartphone, semisal Firefox, Chrome, Opera, Opera Mini, UC Browser dan lainnya. 

Terdapat lima kelompok kode respon HTTP, dimana digit pertama dari setiap kode menyatakan salah satu dari kelima kelompok tersebut. Kode status HTTP didaftar dan disusun oleh Internet Assigned Numbers Authority (IANA). Namun demikian, Microsoft IIS terkadang menggunakan desimal tambahan sub-kode untuk memberikan informasi yang lebih spesifik, tetapi ini tidak tercantum di sini.



Kode Informasi 1xx
Permintaan diterima, proses dilanjutkan.
kelompok status kode ini menunjukkan respon sementara, hanya terdiri dari Line Status-dan header opsional, dan diakhiri oleh sebuah baris kosong. Karena HTTP/1.0 tidak mendefinisikan kode status 1xx, server tidak harus mengirim tanggapan 1xx ke klien HTTP/1.0 kecuali dalam kondisi eksperimental.

100 Continue
Ini berarti bahwa server telah menerima header permintaan, dan klien harus melanjutkan untuk mengirim request body (dalam kasus request body yang perlu dikirim, misalnya, POST request). Jika request body besar, pengiriman ke server ketika permintaan telah ditolak berdasarkan header yang tidak efisien. Agar server memeriksa apakah permintaan dapat diterima berdasarkan header permintaan itu saja, klien harus mengirimkan Expect: 100-continue sebagai header dalam permintaan awal dan memeriksa apakah kode status 100 Continue diterima dalam respon sebelum melanjutkan (atau menerima 417 Expectation Failed dan tidak melanjutkan).

101 Switching Protocols
Ini berarti pemohon telah meminta server untuk beralih protokol dan server mengakui bahwa ia akan melakukannya.

102 Processing ( WebDAV , RFC 2518)
Sebagian request WebDAV mungkin berisi banyak sub-permintaan yang melibatkan operasi file, mungkin diperlukan waktu yang lama untuk menyelesaikan permintaan.Kode ini menunjukkan bahwa server telah menerima dan memproses permintaan, tetapi respon belum tersedia. Hal ini untuk mencegah klien keluar dengan asumsi permintaan itu hilang.


Kode Sukses 2xx
kelompok kode status ini menunjukkan tindakan yang diminta oleh klien diterima, dipahami, diterima dan diproses dengan sukses.

200 OK
Standar respon untuk permintaan HTTP yang sukses. Respon yang sebenarnya akan tergantung pada metode yang digunakan dalam permintaan. Dalam permintaan GET, respon akan berisi entitas sesuai dengan sumber daya yang diminta. Dalam permintaan POST respon akan berisi entitas menggambarkan atau mengandung hasil dari tindakan.

201 Created
Permintaan telah terpenuhi dan menghasilkan sumber daya baru yang diciptakan.

202 Accepted
Permintaan telah diterima untuk diproses, tetapi pengolahan belum selesai. Permintaan mungkin atau tidak mungkin pada akhirnya akan ditindaklanjuti, karena akan menjadi batasan saat proses sebenarnya terjadi.

203 Non-Authoritative Information (since HTTP/1.1)
Server berhasil memroses permintaan, tetapi mengembalikan informasi yang mungkin berasal dari sumber lain.

204 No Content
Server berhasil memroses permintaan, tetapi tidak mendapatkan konten apa pun.

205 Reset Content
Server berhasil memroses permintaan, tetapi tidak mendapatkan konten apa pun. Tidak seperti respon 204, respons ini mengharuskan pemohon mereset tampilan dokumen.

206 Partial Content
Server memberikan hanya sebagian dari sumber daya karena rentang header yang dikirimkan oleh klien. Rentang Header digunakan oleh alat-alat seperti wget untuk memungkinkan melanjutkan download terputus, atau membagi download ke bagian-bagian simultan.

207 Multi-Status (WebDAV, RFC 4918)
Isi pesan yang berikut adalah pesan XML Partial Content dan dapat berisi sejumlah kode respon terpisah, tergantung pada berapa banyak sub-permintaan dibuat.

208 Sudah Dilaporkan (WebDAV, RFC 5842)
Bagian dari DAV binding yang telah disebutkan sebelumnya dalam jawaban permintaan, dan tidak disertakan lagi.

226 IM Digunakan (RFC 3229)
Server telah memenuhi permintaan GET untuk sumber daya, dan respon adalah representasi dari hasil satu atau lebih contoh-manipulasi diterapkan pada contoh.

230 Otentikasi Sukses ( RFC 2.229 )
Upaya otentikasi klien berhasil.


Kode Redirection 3xx
Klien harus mengambil tindakan tambahan untuk melengkapi permintaan tersebut.
Kelompok kode status ini menunjukkan bahwa tindakan lebih lanjut perlu diambil oleh agen pengguna untuk memenuhi permintaan. Tindakan yang diperlukan dapat dilakukan oleh agen pengguna tanpa interaksi dengan pengguna jika dan hanya jika metode yang digunakan dalam permintaan kedua adalah GET atau HEAD. Seorang agen pengguna tidak seharusnya secara otomatis mengarahkan permintaan lebih dari lima kali, sejak pengalihan tersebut biasanya diidentifikasikan sebagai infinite loop.

300 Multiple Choices
Menunjukkan beberapa pilihan untuk sumber daya yang bisa klien ikuti. Ini, misalnya, dapat digunakan untuk menyajikan pilihan format yang berbeda untuk file daftar video, dengan berbagai ekstensi , atau disambiguasi kata.

301 Moved Permanently
Permintaan ini dan semua permintaan berikutnya harus diarahkan ke URI yang diberikan.

302 Found
Ini adalah contoh dari praktik industri yang bertentangan dengan standar. Spesifikasi HTTP/1.0 (RFC 1945) diperlukan klien untuk melakukan redirect sementara (ungkapan menggambarkan “Pindah sementara”), tetapi browser populer me-implementasikan 302 dengan fungsi dari 303. Oleh karena itu, HTTP/1.1 menambahkan kode status 303 dan 307 untuk membedakan antara dua perilaku. Namun, beberapa aplikasi Web dan kerangka menggunakan kode status 302 seolah-olah itu adalah 303.

303 See Other (since HTTP/1.1)
Respon terhadap permintaan tersebut dapat ditemukan di bawah URI yang lain menggunakan metode GET. Ketika menerima respon POST (atau PUT / DELETE), harus diasumsikan bahwa server telah menerima data dan redirect harus dikeluarkan dengan terpisah GET pesan.

304 Not Modified
Menunjukkan sumber daya belum diubah sejak diminta terakhir.

305 Use Proxy (since HTTP/1.1)
Banyak klien HTTP (seperti Mozilla dan Internet Explorer ) tidak benar dalam menangani respon dengan kode status ini, terutama untuk alasan keamanan.

306 Switch Proxy
Tidak lagi digunakan.

307 Temporary Redirect (since HTTP/1.1)
Dalam hal ini, permintaan harus diulang dengan URI lain. Namun, permintaan berikutnya masih harus menggunakan URI asli

308 Permanent Redirect (approved as experimental RFC)
Permintaan, dan semua permintaan selanjutnya harus diulang dengan menggunakan URI lain. 307 dan 308 (seperti yang diusulkan) merupakan paralel dari 302 dan 301, tetapi tidak memungkinkan perubahan HTTP metode. Jadi, misalnya, mengirimkan formulir ke sumber daya yang dialihkan secara permanen bisa tetap lancar.


Kode Klien Error 4xx
Kelas 4xx kode status dimaksudkan untuk kasus di mana klien tampaknya telah keliru . Kecuali ketika menanggapi permintaan HEAD , server harus mencakup entitas yang berisi penjelasan tentang situasi kesalahan , dan apakah itu adalah suatu kondisi sementara atau permanen . Kode status ini berlaku untuk setiap metode permintaan . Agen pengguna shoulddisplay setiap entitas termasuk untuk pengguna .

400 Bad Request
Permintaan tidak dapat dipenuhi karena sintaks yang buruk .

401 Unauthorized
Serupa dengan 403 Forbidden , tapi khusus untuk digunakan saat otentikasi yang diperlukan dan telah gagal atau belum disediakan . Tanggapan harus menyertakan kolom header WWW -Otentikasi mengandung tantangan berlaku untuk sumber daya yang diminta . Lihat otentikasi akses Dasar dan Digest otentikasi akses .

402 Payment Required
Reserved untuk penggunaan masa depan . Niat asli adalah bahwa kode ini dapat digunakan sebagai bagian dari beberapa bentuk digital cash atau skema micropayment , tapi hal itu tidak terjadi , dan kode ini biasanya tidak digunakan . Sebagai contoh penggunaannya , namun, layanan MobileMe Apple menghasilkan error 402 jika akun MobileMe yang menunggak . Selain itu, YouTube menggunakan status ini jika alamat IP tertentu telah membuat permintaan yang berlebihan , dan membutuhkan orang untuk memasukkan CAPTCHA .

403 Forbidden
Permintaan yang valid , tetapi server menolak untuk menanggapi itu.  respon tidak sah 401 , otentikasi akan ada bedanya . Pada server di mana otentikasi diperlukan , hal ini biasanya berarti bahwa kredensial yang disediakan berhasil dikonfirmasi tetapi bahwa kredensial masih tidak memberikan izin klien untuk mengakses sumber daya ( misalnya pengguna diakui mencoba untuk mengakses konten terbatas ) .

404 Not Found
Sumber yang diminta tidak dapat ditemukan tetapi mungkin tersedia lagi di masa depan. Permintaan selanjutnya oleh klien diperbolehkan .

405 Method Not Allowed
Permintaan terbuat dari sumber daya menggunakan metode permintaan tidak didukung oleh sumber daya yang , misalnya , menggunakan GET pada formulir yang memerlukan data yang akan disajikan melalui POST , atau menggunakan PUT pada sumber daya read-only .

406 Not Acceptable
Sumber daya yang diminta hanya mampu menghasilkan konten tidak dapat diterima menurut Terima header dikirim dalam permintaan .

407 Proxy Authentication Required
Klien harus terlebih dahulu mengotentikasi dirinya dengan proxy .

408 Request Timeout
Server timeout menunggu permintaan . Menurut W3 spesifikasi HTTP : ” Klien tidak menghasilkan permintaan dalam waktu yang server siap untuk menunggu . Klien MUNGKIN mengulangi permintaan tanpa modifikasi pada suatu saat nanti . “

409 Conflict
Menunjukkan bahwa permintaan tidak dapat diproses karena konflik dalam permintaan , seperti konflik penyuntingan .

410 Gone
Menunjukkan bahwa sumber daya yang diminta tidak lagi tersedia dan tidak akan tersedia lagi. Ini harus digunakan bila sumber daya telah sengaja dihapus dan sumber daya harus dibersihkan . Setelah menerima kode status 410 , klien tidak harus meminta sumber daya lagi di masa depan . Klien seperti mesin pencari harus menghapus sumber daya dari indeks mereka . Kebanyakan kasus penggunaan tidak memerlukan klien dan mesin pencari untuk membersihkan sumber daya , dan ” 404 Tidak Ditemukan ” dapat digunakan sebagai gantinya.

411 Length Required
Permintaan tidak menentukan panjang isinya , yang dibutuhkan oleh sumber daya yang diminta .

412 Precondition Failed
Server tidak memenuhi salah satu prasyarat yang pemohon memakai permintaan .

413 Request Entity Too Large
Permintaan lebih besar dari server bersedia atau mampu memproses .

414 Request-URI Too Long
The URI disediakan adalah terlalu lama untuk server untuk diproses.

415 Unsupported Media Type
Entitas permintaan memiliki jenis media yang server atau sumber daya tidak mendukung . Sebagai contoh, klien upload gambar sebagai image / svg + xml , tetapi server mensyaratkan bahwa gambar menggunakan format yang berbeda .

416 Requested Range Not Satisfiable
Klien telah meminta untuk sebagian dari file , tetapi server tidak dapat menyediakan bagian itu . Sebagai contoh, jika klien meminta bagian dari file yang terletak di luar akhir file .

417 Expectation Failed
Server tidak dapat memenuhi persyaratan Harapkan lapangan request header.

418 I’m a teapot (RFC 2324)
Kode ini didefinisikan pada tahun 1998 sebagai salah satu lelucon tradisional IETF April Fools ‘ , dalam RFC 2324 , Hyper Text Coffee Pot Control Protocol , dan tidak diharapkan untuk dilaksanakan oleh server HTTP yang sebenarnya .

420 Enhance Your Calm (Twitter)
Bukan bagian dari standar HTTP , tapi dikembalikan oleh Twitter Search dan Trends API ketika klien sedang tingkat terbatas. Layanan lain mungkin ingin menerapkan kode 429 Terlalu Banyak Permintaan respon gantinya.

422 Unprocessable Entity (WebDAV; RFC 4918)
Permintaan itu well-formed tetapi tidak harus diikuti karena kesalahan semantik .

423 Locked (WebDAV; RFC 4918)
Sumber daya yang sedang diakses terkunci .

424 Failed Dependency (WebDAV; RFC 4918)
Permintaan gagal karena kegagalan permintaan sebelumnya ( misalnya PROPPATCH a) .

424 Method Failure (WebDAV)
Menunjukkan metode ini tidak dijalankan pada sumber daya tertentu dalam ruang lingkup karena beberapa bagian dari pelaksanaan metode gagal menyebabkan seluruh metode untuk dibatalkan .

425 Unordered Collection (Internet draft)
Didefinisikan dalam naskah ” WebDAV Lanjutan Koleksi Protocol ” , tetapi tidak hadir dalam ” Web didistribusikan Authoring dan versi ( WebDAV ) Memerintahkan Koleksi Protocol ” .

426 Upgrade Required (RFC 2817)
Klien harus beralih ke protokol yang berbeda seperti TLS/1.0 .

428 Precondition Required (RFC 6585)
Server asal memerlukan permintaan untuk menjadi bersyarat . Dimaksudkan untuk mencegah ” ‘ hilang update’ masalah , di mana klien GETS negara sumber daya itu , memodifikasi , dan menempatkan kembali ke server , ketika sementara pihak ketiga telah diubah negara pada server , yang mengarah ke konflik . “

429 Too Many Requests (RFC 6585)
Pengguna telah mengirim terlalu banyak permintaan dalam jumlah waktu tertentu . Ditujukan untuk digunakan dengan skema rate limiting .

431 Request Header Fields Too Large (RFC 6585)
Server tidak bersedia untuk memproses permintaan tersebut karena baik sebuah kolom header individu, atau semua field header kolektif , terlalu besar .

444 No Response ( Nginx )
Digunakan di Nginx log untuk menunjukkan bahwa server telah kembali tidak ada informasi ke klien dan menutup koneksi ( berguna sebagai pencegah malware ) .

449 Retry With (Microsoft)
Sebuah ekstensi Microsoft . Permintaan harus retried setelah melakukan tindakan yang tepat. Seringkali search- engine atau aplikasi kustom akan mengabaikan parameter yang diperlukan . Jika tidak ada tindakan standar yang tepat , website Aviongoo  mengirimkan ” HTTP/1.1 449 Coba lagi dengan parameter yang valid : param1 , param2 , . . . ” Respon. Aplikasi dapat memilih untuk belajar , atau tidak .

450 Blocked by Windows Parental Controls (Microsoft)
Sebuah ekstensi Microsoft . Kesalahan ini diberikan ketika Windows Parental Controls dihidupkan dan memblokir akses ke halaman web yang diberikan .

451 Unavailable For Legal Reasons (Internet draft)
Ditetapkan dalam draft internet “A New Status HTTP Kode Sumber Daya Legally – terbatas” . Dimaksudkan untuk digunakan ketika akses sumber daya ditolak karena alasan hukum , egcensorship atau mandat pemerintah memblokir akses . Sebuah referensi untuk 1953 baru dystopian Fahrenheit 451 , di mana buku-buku yang dilarang.

451 Redirect ( Microsoft )
Digunakan Exchange ActiveSync jika ada baik adalah server yang lebih efisien untuk menggunakan atau server tidak dapat mengakses kotak pesan pengguna .
Klien seharusnya kembali menjalankan protokol HTTP Autodiscovery untuk menemukan server lebih cocok .

494 Request Header Too Large (Nginx)
Nginx kode internal mirip dengan 431 tapi itu diperkenalkan sebelumnya .

495 Cert Error (Nginx)
Kode internal Nginx digunakan ketika klien SSL kesalahan sertifikat terjadi untuk membedakannya dari 4XX dalam log dan halaman kesalahan redirection .

496 No Cert (Nginx)
Kode internal Nginx digunakan ketika klien tidak memberikan sertifikat untuk membedakannya dari 4XX dalam log dan halaman kesalahan redirection .

497 HTTP to HTTPS ( Nginx )
Nginx kode internal digunakan untuk permintaan HTTP biasa yang dikirim ke port HTTPS untuk membedakannya dari 4XX dalam log dan halaman kesalahan redirection .

499 Client Closed Request (Nginx)
Digunakan di Nginx log untuk menunjukkan bila koneksi telah ditutup oleh klien sementara server masih memproses permintaan , membuat server yang dapat mengirim kode status kembali .


Kode Server Error 5xx
Server gagal untuk memenuhi permintaan tampaknya valid.
Kode status respon dimulai dengan digit ” 5 ” menunjukkan kasus-kasus di mana server menyadari bahwa mereka telah mengalami kesalahan atau sebaliknya tidak mampu melakukan permintaan . Kecuali ketika menanggapi permintaan HEAD , server harus mencakup entitas yang berisi penjelasan tentang situasi kesalahan , dan menunjukkan apakah itu adalah suatu kondisi sementara atau permanen . Demikian juga , agen pengguna harus menampilkan setiap entitas termasuk untuk pengguna . Kode respon ini berlaku untuk semua metode permintaan.

500 Internal Server Error
Sebuah pesan kesalahan generik , diberikan bila tidak ada pesan yang lebih spesifik cocok .

501 Not Implemented
Server baik tidak mengenali metode permintaan , atau tidak memiliki kemampuan untuk memenuhi permintaan tersebut .

502 Bad Gateway
Server bertindak sebagai gateway atau proxy dan menerima respon tidak valid dari server upstream .

503 Service Unavailable
Server saat ini tidak tersedia ( karena kelebihan beban atau bawah untuk pemeliharaan ) . Umumnya, ini adalah negara sementara .

504 Gateway Timeout
Server bertindak sebagai gateway atau proxy dan tidak menerima respon yang tepat waktu dari server hulu .

505 HTTP Version Not Supported
Server tidak mendukung versi protokol HTTP yang digunakan dalam permintaan .

506 Variant Also Negotiates (RFC 2295)
Negosiasi konten transparan untuk hasil permintaan dalam referensi melingkar .

507 Insufficient Storage (WebDAV; RFC 4918)
Server tidak dapat menyimpan representasi yang dibutuhkan untuk menyelesaikan permintaan .

508 Loop Detected (WebDAV; RFC 5842)
Server terdeteksi infinite loop saat memproses permintaan ( dikirim sebagai pengganti 208 ) .

509 Bandwidth Limit Exceeded (Apache bw/limited extension)
Kode status ini , sementara yang digunakan oleh banyak server , tidak ditentukan dalam RFC .

510 Not Extended (RFC 2774)
Ekstensi lebih lanjut untuk permintaan yang diperlukan untuk server untuk memenuhinya .
511 Network Authentication Required (RFC 6585)
Klien perlu mengotentikasi untuk mendapatkan akses jaringan . Dimaksudkan untuk digunakan oleh mencegat proxy yang digunakan untuk mengontrol akses ke jaringan ( misalnya ” captive portal ” digunakan untuk meminta kesepakatan untuk Persyaratan Layanan sebelum memberikan akses internet secara penuh melalui hotspot Wi – Fi ) .

531 Access Denied (RFC 2229)
Klien otentikasi upaya itu tidak berhasil .

598 Network read timeout error (Unknown)
Kode status ini tidak ditentukan dalam RFC , tapi digunakan oleh Microsoft Corp HTTP proxy untuk sinyal jaringan membaca batas belakang proxy untuk klien di depan proxy .

599 Network connect timeout error (Unknown)
Kode status ini tidak ditentukan dalam RFC , tapi digunakan oleh Microsoft Corp HTTP proxy untuk sinyal jaringan batas waktu connect balik proxy untuk klien di depan proxy.